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What’s In It For Real Programmers?

1. Write code 6. Use autocomplete
2. Run shortcuts 7. Format output

3. Use visuals 8. Store everything
4. View data sets 9. Run batch

5. Get help 10.Use tasks

1. Write code

Open SAS® Enterprise Guide
File > New > Program

Start typing

Have a good day




Program tab

r — o
[@ 54 Enterprise Guid [e=mel=h
nterprise Guide N el i
File Edit View Tasks Program Tools Help |- 5 @ | 5 o B3 B X |9 o |- _
Project Tree + x Program ~
B-gg Process Flow E.ﬂ Program |
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Refresh |
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Ready | ¥ 54593 | Functions: Restricted

2. Run shortcuts [built-in]

Ctrl + Shift + F = Formats

Ctrl + Shift + | = Informats

Ctrl + Shift + F1 = Functions

Ctrl + Shift + F2 = Macro Functions
Ctrl + L = Libraries

Ctrl + D = Data sets

Ctrl + A, Ctrl + C, Ctrl + V, etc. work as usual

Ctrl + / = comment; Ctrl + Shift + / = uncomment




| demo2.
2. Run shortcuts [user-created]

* Program > Editor Macros > Record New
= Stop Recording; Assign keys

Ctrl + R = repeat line
Alt + D = delete line
Shift + Ctrl + | = insert initials and date stamp

F7 = go to previous step; F9 = go to next step
Shift + F8 = highlight step
Shift + F9 = add next step

Running programs

Click the Run button »run - @

Press F8 or F3
= Runs whole program or selected lines

Open the Run menu and click
= Run
= Run Selection

Right-click program in Project Tree
and select Run Program




Monitoring programs

= Job progress is reported at the bottom left

ﬁ (Details] Running: Program - Running DATA step...

= Click the red Stop button to cancel a program

@ Stop

3. Use visuals

& Progrem || Z] Log [ 5 Output Data|
HSave = b Run = 1 Stop | Selected Server: Local (Connected) + %, | Analyze Program ~ | Export + SendTo = Creste - | [ Properties

*1. No WARNING or ERROR;
Ddata temp;

set sashelp.class;
wherse sex='F'";

run;

*2. WARNING;

porc print data=temp;

var age;

title 'PRINT of Females';
run;

%] Program® = not saved

&] Program = ran without WARNING or ERROR ———————
Ctrl + Shift + Tab) to

&) Progrsm = has at least one WARNING O3 RS0 ELE

1] Program = has at least one ERROR




4. \View data sets

[&] Program | [Z] Log | &3 Output Data ‘

&5 | i Filter and Sort £ Query Builder

Data ~ Describe » Graph ~ Analyze ~

Export = Send To - @ putton to view PROC

[ WName |A  Sexs |@  Age [@ Height |3 weight [[E  DOB

1 [Aed 0 Type Character & 1125 0R/2B2013
2 |Hce F Length: 1 55 [ 067282013
3 Barbara F Label: Student gender 653 a3 06/28/2013
4 |Carci F i 1] 25 0872875013
5 |Henry M Rl over a variable. 14 83 1025 087282013
§ |James I e 573 8 D8/28/5013
7 |Jane F play Its Type, 35 558 i 087265013
8 |Janet F Length, and Label. g &5 i135 D&i3E5013
9 |Jefrey i [ &5 8 067282013
10 | Jshn i i 5 55 DEI3E5HT3
11 [Joyee F i 513 505 067282013
12 |Judy F i (75 5 087285013
13 |Louise F i 553 77 D8/28/5013
14 [Viary F is i 0872875013
15 | Fhilip i i 150 D8I282013
16 | Robert T ) 28 087285013
17 [Fonald i i i3 DEI3E5HT3

i i 7 g 067282013

i i 85 i1 DEBE5ETS

Click the Properties

CONTENTS-type info.

£ = character
@ = numeric

[] = date

Properties button > Columns

Properties for TEMP

Summary

Columns.
Name Type Length Fomat Informat Label
Name Character Studert name
Sex Character 1 Studert gender
Age Numeric 8 Student age
Height Numeric 8 Studert height (nches)
Weight Numeric 8 Studert weight (pounds)
DOB Date 8 MMDDYY1D. June 2013 BASUG meeting
Copy te cipbeard
Label that identfies the data set. Specified by the LABEL= option B
More (F1).. =




5. Get help

] Program =] Log

[ Save = I+ Run = (1 Stop | Selected Server: Local (Connected) ~ %
mdata temp;
set sashelp.class;
Keyword: SET @)
Context: [DATA STEP] SET statement

Syntax: SET <SAS-data-set(s) <(data-set-options(s) )>> <options;
Reads an observation from one or more SAS data sets hes) '

'
Search: The Produict Dogumertation, Samples & SAS Motes, Papers [°35)
€ ting';

124
format dob mmddyyl0.;

run;

Roll over a word for context-sensitive help and links to:
@ support.sas.com

® Online documentation

©® Sample code and Usage Notes

@ Technical papers and SAS Global Forum proceedings

6. Use autocomplete

SAS suggests ways to complete word

Commands, keywords, and options

Libref, data set name, and variables

Accept suggestion

= <Spacebar>, <Enter>, or <Tab>

" Punctuation; , . () [1 {} <>/ ~ + -
Keep typing

= |[gnore suggestions




Autocomplete suggestions

(i MAPS [ ancomp

(i) MAPSGFK [5d ADOMSG

(i) MAPSSAS [} ADsMsG

(i) SASHELP "] AFMSG

(i} SASUSER [

[ temp "] APPLIANCESERIES
(4P WORK [} AsscmGR

[ emt
-data temp; [ BuY
set libref.filename;

where sex='F';

run;

Jproc print data=libref.filenams;
title 'PRINT of Females in SASHELP.CLASS';
run;

sproc means data=libref.filenams;
var variable[s]:

title 's ary statistics on Females';
run;

b Age

@ Height

@ Weight

Functions and PROCs

Fdata temp2;

set sashelp.class;

first_initial=substr(
a 10of 2+ SUBSTRistring, position<, length:}
string:

Specifies a character constant, variable, or expression

Zproc freq data=temd ——— ' COMPRESS
tables age*sex/ (' FORMCHAR(1,27}=

(i FORMCHAR=
i NLEVELS PROC FREQ statement options
(‘! NOPRINT
('i' ORDER=
1! PAGE

i AGREE

i ALL

i ALPHA=

i BDT

1! BINOMIAL TABLES statement options

i BINGMIALC

i CELLCHIZ

i CHISQ

Pl -
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People love it or hate it

| TRIED AUTOCOMPLETE ONCE

21

Adjust settings

o —
Enhanced Editor Options =

General | Appearance | [ Inderter |

Enable Autocomplete:

Pr—
Commit a selection when typing any of these symbels:
0. +-<>101/~

#dd spaces when commiting with these symbols

YA

] Add spaces when commiting value4ype options (.. options ending with =)
Comit selection when pressing the SPACEBAR key
Comit selection when pressing the ENTER or TAB key

Autocomplete these Keywords Tools > Options... > SAS Programs >

Macro yatiables Editor Options... > Autocomplete tab
Macro definitions
Macro Statemerts

Global statements
Procedure options
Procedure statements
DATA step statements || Automatic macro variables
Librefs and SAS datasets ] ARM macros

'SAS Colors
Pp—

Integrated Syntax Help

Search Engine:

22




Recommendation: Try it

= You might like it
* Prompts for PROC and statement options
= Roll over suggestions for Help
= Try using Autocomplete on Third character
= Turn off autocomplete of certain keywords

/. Format output
= Multiple choices |
= SAS Report -

= HTML

= PDF

= RTF

= Text output

[IeoF

= Check one or more boxes
= Results “published” to each destination
= Text output is fastest

24




Multiple output formats

v

&) Program [ Z] Log [ 53 Output Data | @) Resuits -SAS Report | ] Resuls -HTML | T5) Resuts -POF [ ] Resuts - RTF | [ Resuts -Listng |

Save + |~ Run = (1 Stop | Selected Server: Local (Connected) = %, | Analyze Program = | Export = Send To + Create ~ | [ Properties

-data temp;
set sashelp.class;
where sex='F';
run;

*Turn on SAS Report, HTML, PDF, RTF, and Text ocutput;
Jproc print data=temp;

title 'PRINT of Females';

run;

. £ Females
emales
PRINT of Females | PRINTofFemales | ppinT of Females
- Name
Obs/Name |Sex | Ag| ©bs Mame  Sex Aol Lo T e [Sex |age | Helant | Welght] o2 Weieht
1Alice F 1) taee FoL o PR |7 | 3] ses| sso)” SO tice
2 Barbara F 1 2| Barbara F 1 N F 980
2| Barbara|F 13| 653 98.0 Barbara
3 Carol F 1| 3|Caol |F 1 HEENE 1a| ezs| 102s|F 14 e28] 1023
a 2 2.3 Carol
4 Jane F 1) 4 Jene F 1 4|ime  |F 12| ses| sasE 2] 588 M3 pne
5 Janet |F 1 5 Janet F 1 Sline |F | 1] e2s] e F | 3] e2s] wmas| oo
6 Joyce F 1 6 Joyce F 1 6oy [ 1l sis 505 |F 11| 513 05| Joyce
T Judy F 1 7dy F 1 ey [ | 14 e ovo|F | 14| 643|900 gudy
8 Louise F 1| & Louise F 1 8| rouise |F 12] ses|[  sofF 12] 363] 770| Louise
9/ Mary F 1 9 May F 1 9[vary [F 15| ess| 1zo]F 15| 665 1120 Mary

Store output externally

= ODS destination FILE='path:\filename.ext';
= SAS code
= RUN;
= ODS destination CLOSE;
= HTML, PDF, and RTF

rinted no ¢

statement.)

ods pdf file='c:\files\BASUG\print.pdf';
Zproc print data=temp;

title 'PRINT of Females';

run;

ods pdf close;

26




8. Store everything

g s = e — P —— Y
FEile Edit View Tooks Solutions Window Help {
v cDerESR e DB L0 |
s B[ Resuits iewer - 525 Output
&P Resuits =
@9 ok PRINT of Females i SASHELP CLASS PRINT of Females in SASHELP.CLASS =
{5 Means: Summary statistics on Females
Obs Name Sex Age Height Weight
1 Afred M 1 69.0 125
[ Log - (Unttied) = EoB = |
1 data tenp; ¥
2 set sashelp.class;
3 where sex<'F';
4 run
NOTE : “nzaz were : observations read from the data set SASHELP.CLASS. L
sex="F';
HOTE: Tho data set LORK TENP has § abeorvations ond § vor iables. In PC SAS, the Program,
: DATA statenent u otal process time):
real tine 0.01 seconds Log, and Results must
cpu tine 0.01 seconds . ..
v be saved individually.
Editer - Untitied] *
=proc print data=sashelp.clas b
" Females in zp
Sproc means data=sashelp.class:
on Females'; =
& Fens B Output - Wotited) _|[ETtog-Umtited) (2 Editor- Unetedt * | (@) Results Viewes - 5. |
Done & C:\Users\bost
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Enterprise Guide Project

SAS Enterprise Guide - The Enterprise Guide 5.

Click the Save Project button
File Edit Vi Tasks P Tools  Hel - 5 1 | s t ¢
e t tew e togiam _ Tools  tielp | B~ G- ) |t or File > Save Project As...

demo 8 - store everything =

ag?gig__‘mcess Flow [#] Program Log Output Data | [ Rssults

=] Programs

0 ~ Save = B Run - [ Stop | Selected Server: SASApp (Conned . .
demo 1 - standard shortcuts In Enterprise Guide,
demo 2 - custom shortcuts =data temp; he P L d
) demo 3 -use visuals set sashelp.class; the Program, Log, an

L :emu;—wev:‘:ata sets where sex—'r': Results are stored in a
£] demo 5 - get help i N 3
] demo 6 - autocomplete run; single .EGP file.

demo 7 - output formats
-~ [#] demo 8- store evenything

A ————
D& > » Computer » Windows7(C) » FILES » BASUG

Organize v Includeinlibrary v Sharewith v New folder
P Fivoiitas “  Name Date modified Type Size
Bl Desktop | @ The Enterprise Guide 5.1 Experience.egp|  6/22/20135:06 PM  5AS Enterprise Guide Project 23K8

18 Downloads

=] Recent Places

28




9. Run batch

= Multiple programs stored in one project

= Series of related programs

= Programs to run in sequence

= Each Program has its own Log and Results

29

. .
File > Run project |
=
SAS Enterprise Guide - The Enterprise Guide 5.1 Experience.egp %
Edit View Tasks Program Tools Help |- G5- @ | & 32
demo - run batch ~ =

-Beg Process Flow
£-(7 Programs
demo 1 - standard shortcuts

(&) Program |[2] Log)

Save » I Run ~ [ Stop | Selecte i

File | Edit View Tasks Program Tools Help

New 3
Open >
Close Project

Save The Enterprise Guide 5.1 Experience  Ctrl+S
Save The Enterprise Guide 5.1 Experience As...
Save demo 3 - run batch Ctrl+Shift+5

Save demo 9 - run batch As...

Import Data

demo 2 - custom shortcuts *demo 9: | = Run The Enterprise Guide 5.1 Experience E
demo 3 -use visuals Run programs indivi Schedule The Enterprise Guide 5.1 Experience
demo 4 - view data sets . .
demo 5 - get help File > Run [p:oje:t| Export N
demo 6 - autocomplete Send To o
demo 7 - output formats .
dema 8 - tore everything Hy  Publish
demo 3 - un batch P Page Setup for demo 9 - run batch..
demo 10 use tasks
Print Preview for demo 9 - run batch
S, Printdemo 9 - run batch... Ctrl+P
ol m@ E] Project Properties
Recent Projects 3
€ Refresh | Disconnect | Stop
Recent Programs >
A Servers -
i
4 »
Ready “& SA59.3 | Eunctions: Restricted | Linel, Coll .:

30




Process Flow

= View > Process Flow
" F4 toggle
= Visual summary of
® Programs
= Logs
= Listings
= Other output types

Data sets
= And more...

SAS Enterprise Guide - The Enterprise Guide 5.1 Experence.cap T
File Edit View Tasks Program Tools Help |- 5~ @

IprojectTree = x ProcessFlow -
5-Beg Process Flow b Run - [ Stop | Export - Schedule +
& Programs
i~ [#] demo 1 - standard shortouts
-t
T dam demo7 - Log
: ﬁde output fo.
e
- [&] dem N
H @;ﬂa
L e Listing -
= demo 7.
A
cifilest
demo 8- Log
store eve.
Listing -
demo 8-

31

10. Use tasks

Tasks are wizards

= SAS generates code for you

"Danger, Will Robinson!

You are real programmers

= You do not know everything

Use tasks to generate code

= Copy/edit what is generated

Good for unfamiliar PROCs

32




Summary Tables Wizard...

= Tasks > Describe > Summary Tables Wizard...

] Summary Tables for LocakSASHELP.CLASS =)
2 of6  Selectanalysis variables and staistics §SaS
[ Analysis variables: Previon
Sﬂame Statistic P ‘ He‘gm‘ \wgm‘
@) hoe Average .
@ Heian sversse S [ p— Check out the preview of
i we | ome | we the table to be produced.
@ Veisht - sex
999 999 999
|
|
Analysis varable labels: in columns
Statistics labels: in columns. Select table format
[ ook ][ Hetr ][ Finish |[ Concel |[ hHep |

33

Work with generated code

Open task
Click on Code tab

Double-click inside —
= Click Yes button

SAS Enterprise Guide @J

This code is read-only.
Do you want to create a copy of this code that can be modified?

SAS adds program 7
to current project —

El Code For Summary Tables

Edit as needed

L

34




Summary

use SAS Enterprise Guide to

1. Write code 6. Use autocomplete
2. Run shortcuts 7. Format output

3. Use visuals 8. Store everything
4. View data sets 9. Run batch

5. Get help 10.Use tasks

There are many additional features to
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Selected Publications by Christopher Bost

2006.

2006.

2007.

2007.

2008.

2010.

2011.

2011.

2012.

2012.

2013

2013.

Identifying duplicate values

Subsetting observations from large SAS® data sets

Automatically renaming common variables before merging

Transposing data without PROC TRANSPOSE

Effective presentations for SAS® training and more

Automatically converting character variables that store numbers to numeric variables
Making SAS® training stick®

To FREQ, perchance to MEANS

Magic spells with SAS®

Selecting all observations when any observation is of interest®

. Checking out your dates with SAS®

Dealing with duplicates

! Awarded best contributed paper for Planning and Support at SAS Global Forum.

2 Awarded best contributed paper for Programming: Foundations and Fundamentals
at SAS Global Forum.
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