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Presenter
Presentation Notes
Abstract: The next generation of SAS Enterprise Guide (EG) is here! The redefined EG 8 is both sexy and intelligent. EG 8 sports a modern and attractive interface, tab-based organization of content, and flexible window management such as floating, docking, and leveraging multiple monitors. Want to view your code, log, and results at the same time? EG 8 has you covered. Want to view four data sets at the same time? Sure, no problem. Want to just code, without a project? You got it.Subject to the disclaimers below, the goal of this presentation is to show new features for SAS Enterprise Guide 8.1 and 8.2.  Legal Disclaimers:Please note that roadmap information aims to outline general product direction and should not be relied on in purchase decisions. The delivery and timing of any future functionality described for our products is subject to change without prior notification. Information regarding potential future products is not a commitment or obligation to deliver any code or functionality, and in no way represents contractual obligation by SAS. March 2020
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Why Update SAS Enterprise Guide?
Things we can do better

Max 2 
tabs

Single 
monitor

Annoying 
modal 
dialogs

Forced 
to work 
with a 
project

Dated 
look

Data 
locking
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The Plan
Modernize, Yet Keep the Essence

• Why?
• Supporting the work you do
• Listening and responding to your feedback
• Interchangeability with SAS Studio

• How?
• Attractive, flexible, smart
• Take advantage of being a desktop app

• When?
• 8.1 released June 18, 2019
• 8.2 released November 19, 2019



Copyright  © SAS Inst itute  Inc.  A l l  r ights reserved.

Meet SAS Enterprise Guide 8

Presenter
Presentation Notes
Corporate themes, consistent with other SAS applications.Light and dark themes. Want to check out Ignite, our dark theme? Go to Options > General and under the Visual Experience section choose Ignite as the color theme. High contrast for accessibility (shown high contrast black)– using whatever the user has set up on the operating system Updated icons throughout.
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After

Onboarding
First Impressions Matter

Before

Presenter
Presentation Notes
By default, the Start Page opens whenever you start EG. It has some helpful topics should you need them, such as quick links to opening a new program or project, learning links and quick links to help you should you experience issues. Once you start opening files the right side now displays these files in a Recent list. You can also pin files. If you find the Start Page useful, you can keep it up. If you accidently close it, you can bring it back by going to View > Start Page. On the other hand, if you don’t want to see the Start Page whenever you open EG you can go Options > Start Up and uncheck Show Start Page. By the way, while you are in Options check out the other items you can automatically open (or not) at start up. 
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Refresh the Look

Presenter
Presentation Notes
SAS Enterprise Guide needs a face-lift – let’s face it. Refreshed COLOR icons, flatter look.Originally SAS Enterprise Guide was going to have monochromatic icons, but the SAS Enterprise Guide users were very vocal – on SAS Communities, emails, in-person – about losing color. We listened, we adapted. We love hearing from our users.QUESTION: Does this look familiar to you as a current SAS Enterprise Guide user?
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Refresh the Look

Presenter
Presentation Notes
The layout is all about maximizing the space and efficiency needed to code and build process flows, while leaving ample room to browse and access the full context of your files or project. The UI is divided into five areas:Navigation Bar and Panes - Contains different panes like the Project, Servers, Tasks panes to assist you while working on your project or program.Workspace - The main area to work directly within your files. You can open as many tabs as you like, side by side vertically and horizontally.Status Bar - Information about the files you edit and submit.Tools Area - You can display different panes below the workspace region for viewing status. Tools panes can also be moved around for more vertical space.Profile Connection Indicator– indicates which profile you are working in
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The Navigation Panes

Most of the panes are trees that contain folders and files. You can do many 
things from them: 
• Create, delete, and rename files and folders. 
• Move files and folders with drag and drop. 
• Use the context menu to explore all options. 

Tip: Drag and drop these panes and use the Layout Guide to 
help you position them where you like them. 

Open Items - At a glance you can see a list of your currently 
opened files. 

New

New
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Flexible Layout
Tab groups, floating, docking, oh my!

Before: Max 2 tabs and single monitor

After: Unlimited tabs & multiple monitors

Presenter
Presentation Notes
You might be limited to one monitor or you might have six, but inevitably you want to see a lot more than one thing at a time. Something that’s new in SAS Enterprise Guide 8 is the ability to have multiple tabs of information open and drag them around as you like. 
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Working with Code, Log, Results
At the Same Time!

Before: Choose which ONE to view After: View ALL

Presenter
Presentation Notes
You can open as many tabs as you like side-by-side, vertically and horizontally. For example, open multiple data sets to compare them. In addition, within a Program (.sas file), you can rearrange the secondary tabs (Code, Log, Results, Output Data). Maybe you want to see the log on the right and watch it stream?
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Working with Code, Log, Results
Drag a tab then use the Layout Guide to help you position the tab

Presenter
Presentation Notes
Use the Layout Guide to customize where your tabs appear.
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Working with Code, Log, Results
Or use preset layouts

Presenter
Presentation Notes
Commonly used layouts are available from the View menu.When working with your various window layouts you sometimes will get to the point where you just want to start over. Go to View > Restore default layout. 
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Float a Tab Within the App or To Another Monitor

Presenter
Presentation Notes
Float a tab. Once floated you can quickly dock it again. 
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Working with a Project or NOT!
Program-centric Development

Before: Project required! After: Project optional!

Presenter
Presentation Notes
One of the biggest changes that we have made to SAS Enterprise Guide, that we are quite proud of, is that you decide if you want to work with a project or not. This means that you can now use it as a tool to open and work on single files or use it to open a project and work with all the files there as a group. By default, SAS Enterprise Guide 8 does not start up with a project open. 
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I love the way EG adds 
files to projects and 
process flows for me

Adding Files to a Project
Automatically

Option to automatically add 
items to a project

Presenter
Presentation Notes
There are lots of ways people would like to work in SAS Enterprise Guide – there are three distinct groups of people:There are the people that LOVE the way SAS Enterprise Guide  currently works. They love the way that SAS Enterprise Guide  automatically adds files that they work with into a project and a process flow.
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I love the idea of a 
projects and process 

flows, but I want to add 
files myself

Add Files to a Project
Manually

Presenter
Presentation Notes
There are some users who while they like the “concept” of a project, they would like to be able to add files to a project/process flow when they need to, as opposed to SAS Enterprise Guide  doing it for them.   They can build a project when they want to organize or manage a bunch of filesselect a few files in the Server Files pane the files are then added to the project – the user can also add process flows to a project and then determine which files to add to a process flow.
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No Project!

I just want to program – not 
interested in projects or 

process flows

Presenter
Presentation Notes
Then there are the users who just want to code & want nothing to do with projects or process flows (get out of my way & let me code).  Historically these are the users that don’t particularly like SAS Enterprise Guide.So this is a big change – the option to use a project/process flow or not. A  program is open but has no ties to a project. You can work in the .sas file and save it directly to your file system. If you have no interest in projects at all and want to declutter your environment, you can close the Project pane. Click Hide or from the View menu, uncheck Project. You can then bring it back by checking it later. 
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Items That Don’t Require a Project

These items do not require a project. They can be opened and edited in a 
‘project-less’ environment. 
• Programs 
• Data 
• OLAP Cubes 
• SAS Report Results 
• SAS Visual Analytics Reports 
• Logs 
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Working with Tasks

• Tasks now available from the Tasks pane
• Query Builder and Import are automatic favorites
• Still need a project to use tasks
• SAS Studio tasks are available

Presenter
Presentation Notes
Tasks are very popular – especially the Query Builder and Import tasks. By default, these two tasks have been favorited for you so that they are quickly accessible. While Tasks are no longer available from the menu bar, they are available from the Tasks pane, which you can conveniently move to any location or even float it on a different monitor. In 8 you will still need a project to work with tasks. If you have SAS Studio Enterprise or SAS Studio Single User versions installed, you can access the hundreds of SAS Studio tasks that have been written for you. Go to Options > Tasks > SAS Studio Integration and check Display SAS Studio tasks. In SAS Enterprise Guide 8.1, only the built-in SAS Studio are available.  In SAS Enterprise Guide 8.2, you can access your custom SAS Studio 5.2 tasks. 
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Drag and Drop Data Set Names and Variables into a 
Program

Presenter
Presentation Notes
Ever mistyped variable names in your code? Now you can drag the variables into your program and avoid errors in the log. Navigate to a data set in the Servers pane. With a program open, click and drag a data set name into the program.  Drag any columns into a program as well. No need to type and less error prone. 
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Integration with Git

Presenter
Presentation Notes
 The new Git integration user interface integrates some of the most common Git features into SAS Enterprise Guide, including cloning, pulling, pushing, and branching.
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Managing Keyboard Shortcuts

Presenter
Presentation Notes
You can customize the keyboard shortcuts for some commands. To manage these shortcuts, select Tools then select Manage keyboard shortcuts.To change a shortcut, select the command and enter the new keyboard shortcut in the Primary or Secondary column.You can import a data file with your customized shortcuts or to export your keyboard shortcuts to a file.
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What’s Happening?
Submission Feedback

Before: Some status information After: Knowing status at a glance

Presenter
Presentation Notes
Use the Submission Status (formerly known as the Tasks Status) tool to help you manage all submissions. You can see the status of various submissions and cancel them. While we have tried to improve the cancelling experience within EG, we still must wait until SAS reaches a place where it can gracefully cancel. The status bar will also show you if have any files that ran with errors or warnings. 
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Running Multiple Items without Locking the UI 
Status icons

Program is queued in the order of submission. 

Program is in the process of being submitted. 

Status icons will show you, at a quick glance, if 
your program ran with errors or warnings.

Presenter
Presentation Notes
Run a project or, if you are not using a project, run more than one program. Even while one or more programs are running you can work in other programs. You will see several icons display in various places such as the tab itself or next to the file in the Project or Open Items panes. 
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Opening Files
Before After

Presenter
Presentation Notes
See status of files that are open – queued to be submitted, submitting, need to be savedOrganize tabs – close, rearrange
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Output Data Performance Options

• New options for controlling what output data to open automatically

Presenter
Presentation Notes
Additional performance options for opening generated output data – especially useful if you have wide data or many datasets.If only one data set generated, selecting first or last opens the single data setApplies to the input data tab in addition to the output data tab.
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Search
• Search panel that can toggle on and off
• Search for items in a project and in the Open Files pane

Presenter
Presentation Notes
Searching for an item in a project used to be in the upper-right corner.   It is now a Search panel that you can toggle on or off. Not only can you quickly search for items in a project, but also the items in the Open Files pane. You can launch it in two ways. Click the Search icon in the top toolbar area Go to View > Search. 
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Notifications
What do you really need to know?

• Get out of your way so you can continue working
• Better messaging

Before

After

Presenter
Presentation Notes
Dialogs popping up get in the way. For those notifications that don’t require immediate response, notifications will appear at the top of the UI. You can take action and dismiss when you want.
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Behind the Scenes

• Always responsive
• Gracefully handle server 

unresponsiveness

• More responsible with open 
data 
• Not locking as long
• Not opening when unnecessary

• Improved handling of large 
project logs

• Product help is now online!

Presenter
Presentation Notes
Data sets are no longer locked. Run a program that creates > 3 datasets. Lay them out so that you can see all the created datasets at once. - see what happens when you change the data and resubmit. After 3 minutes of inactivity any open data will be unlocked. This is an option that can be changed Options > Data > Performance then change how many minutes you want before Unlock open data after inactivity. SAS Enterprise Guide help and documentation is now available on the web just like other SAS documentation.  Navigate via the help center or just google to find what you need.
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SAS Enterprise Guide and SAS Studio
Future Forward

SAS Studio

SAS Enterprise Guide
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Join the Discussion
Tell us what you like, don’t like, what more you need

On SAS Communities:
• SAS Enterprise Guide 

community – find it 
under Business 
Intelligence

• SASware ballot ideas 

Presenter
Presentation Notes
What’s new summaries are available in the online doc and this FAQ entry - https://support.sas.com/software/products/enterprise-guide/faq/whatsnew.htm . And be sure to tell us what you want via the SAS Enterprise Guide community and SASware ballot on communities.sas.com.For easy access to documentation, training, and other resources  -  https://support.sas.com/en/software/enterprise-guide-support.html To see a longer version of this presentation, the Ask the Expert series contains https://communities.sas.com/t5/Ask-the-Expert/What-s-New-in-SAS-Enterprise-Guide-8-1/ta-p/578528 
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